공지사항
보안패치
결제방법안내
서비스 이용약관
개인정보취급방침
자주묻는질문
기술가이드
문의하기
제 목 리눅스 Ghost 취약점 보안 업데이트 권고
작성자 관리자 ( se@hhosting.co.kr ) 등록정보 2015-01-29 15:59:54 조회수 7413
□ 개요

o 미국 US-CERT는 리눅스 GNU C 라이브러리(glibc)에서 임의코드를 실행할 수 있는 취약점(CVE-2015-0235)이 발견되었다고 발표

※ CVE-2015-0235는 해당 라이브러리의 gethostbyname( ) 함수 처리 과정에서 발생하는 버퍼오버플로우 취약점

※ GNU C 라이브러리 : 리눅스 계열 운영체제에서 기본적으로 사용하는 소프트웨어


□ 취약점 내용

o 라이브러리에 존재하는 특정 함수(__nss_hostname_digits_dots( ))의 잘못된 메모리 사용으로 인해 오버플로우가 발생하여 프로그램의 실행 흐름 변경이 가능

※ __nss_hostname_digits_dots( ) 함수 : 도메인 주소를 IP 주소로 변환할 때 사용하는 함수인 gethostbyname( )를 호출 시 내부적으로 호출되는 함수


□ 해당 시스템

o 영향을 받는 시스템

- glibc 2.2~2.17버전의 모든 리눅스 시스템


□ 해결 방안

o 취약한 버전의 라이브러리를 사용하는 시스템은 상위 버전으로 업데이트

※ 실행파일에 취약한 버전의 라이브러리를 포함하여 컴파일 한 경우, 상위 버전의 라이브러리로 재컴파일 하여 설치 필요

o 다음 참고사이트의 내용을 참조하여 보안업데이트 수행

- CentOS [1]
- Debian [2]
- Redhat [3]
- Ubuntu [4]


□ 기타 문의사항

o 한국인터넷진흥원 인터넷침해대응센터: 국번없이 118


[참고사이트]

[1] http://lists.centos.org/pipermail/centos/2015-January/149413.html
[2] https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=776391
[3] https://access.redhat.com/articles/1332213
[4] http://www.ubuntu.com/usn/usn-2485-1/

총 171 건
번호 제목 등록일 조회수
171 OpenSSL 긴급 보안 업데이트 2016-03-03 3659
170 윤초(Leap Second) 관련 버그 내용 및 대응 방안 안내 2015-06-26 6339
169 HTTP.sys 원격코드 실행 취약점 2015-04-17 6977
=> 리눅스 Ghost 취약점 보안 업데이트 권고 2015-01-29 7413
167 Apache Struts 2 원격코드 실행 취약점 보안업데이트 권고 2013-07-22 16856
166 국내 공개 웹 게시판(그누보드) 보안 업데이트 권고 2011-04-28 21964
165 MS Internet Explorer 신규 원격코드실행 취약점 주의 - 2010-12-22 2010-12-22 23566
164 국내 공개 웹 게시판(제로보드) 취약점 주의 - 2010-12-22 2010-12-22 22348
163 [MS 보안업데이트]2010년 12월 MS 정기 보안업데이트 권고 - 2010-12-15 2010-12-15 19242
162 애플 퀵타임 플레이어 보안업데이트 권고 - 2010-12-09 2010-12-09 14664
161 Adobe Reader/Acrobat 취약점 보안 업데이트 권고 - 2010-11-17 2010-11-17 15427
160 [MS 보안업데이트]2010년 11월 MS 정기 보안업데이트 권고 - 2010-11-10 2010-11-10 14446
159 Adobe Flash Player 다중 취약점 보안 업데이트 권고 - 2010-11-05 2010-11-05 14331
158 Mozilla Firefox 및 Thunderbird 보안업데이트 권고 - 2010-10-28 2010-10-28 14802
157 Adobe Shockwave Player 신규 취약점 주의 - 2010-10-22 2010-10-22 14555
156 [MS 보안업데이트]2010년 10월 MS 정기 보안업데이트 권고 - 2010-10-13 2010-10-13 13854
155 [MS10-070] ASP.NET 관련 MS 비정기 보안업데이트 권고 - 2010-09-29 2010-09-29 14057
154 마이크로소프트 ASP.NET 신규 취약점 주의 - 2010-09-20 2010-09-20 14147
  [1] [2] [3] [4] [5] [6] [7] [8] [9] [10]